View Issue Details

IDProjectCategoryView StatusLast Update
0000315Infinitode 2[All Projects] Infinitode 2public2019-12-05 12:06
ReporterAnonymousAssigned Totherainycat  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
PlatformMobileOSAndroidOS VersionAny
Product Version 
Target VersionFixed in Version 
Summary0000315: Timed research fails to unlock at end of timer
Description

I'm on update 1.6.0 on android
I started research "Third Generation (Cannon)", it has a 3 hour cool down window. I played for a little bit more that day then came back the next day.
My research button no longer had a timer on it and when I open the research it shows as incomplete.

I started it a second time thinking maybe I just wasn't paying attention; this time I didn't play the game at all after starting the update.

Checking today I see that I no longer have a research timer going (expected), but the research I selected is still incomplete, plus the teal blueprint now says 0/1

So it consumed resources but didn't unlock the research.

I have only tested the Third Generation (Cannon) research option (twice) so I'm not sure if this impacts other timed research options or if it is a bug with this specific one. (It's kind of a long time to be locked out of research)

Steps To Reproduce

1) Select "Third Generation (Cannon)" and start the upgrade timer.
2) Close app
3) Come back 3 hours later

Observed Result:

  • Research timer is complete and you can enter the research screen
  • The selected research is not complete
  • Resources used to start that research have been consumed
Additional Information

I have several months of play under previous versions in case this matters.

My research for the Cannon was as follows prior to the latest version:
(Going from left to right, top to bottom; all for Cannon)

Explosion range L6
Price L6
Range L7
Projectile speed L7
Max experience level L7

Starting level L2
Upgrade price L6
Third generation incomplete
Second generation complete
First generation complete
Damage L7

Experience generation L3
Experience multiplier L6
Rotation speed L7
Attack speed L7
Max upgrade level L5

TagsNo tags attached.
Attach Tags

Relationships

duplicate of 0000276 closedtherainycat Research disappeared 

Activities

Anonymous

Anonymous

2019-12-04 18:30

reporter   ~0000228

I incorrectly reported my version number (reported from the main screen news section)
The version shown under about is R.1.6.2 (build 109)

Issue History

Date Modified Username Field Change
2019-12-04 18:21 Anonymous New Issue
2019-12-04 18:30 Anonymous Note Added: 0000228
2019-12-05 12:06 therainycat Assigned To => therainycat
2019-12-05 12:06 therainycat Status new => closed
2019-12-05 12:06 therainycat Resolution open => duplicate
2019-12-05 12:06 therainycat Relationship added duplicate of 0000276