View Issue Details

IDProjectCategoryView StatusLast Update
0002219Infinitode 2[All Projects] Infinitode 2public2023-12-20 23:02
ReporterIN_FIAR Assigned Totherainycat  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformAcer Chromebook 11 (mobile / PC)OSChromeOS Versioni dunno
Product Version 
Target VersionFixed in Version 
Summary0002219: Tesla ball lightning not counting towards tesla kills missions
Description

When you have Tesla spawn a ball lightning (ultimate ability), when the ball lightning kills something, it doesn't count as a kill towards quests that require Tesla to kill a certain number of enemies. This basically renders this ability useless, because the ball lightnings will take almost every kill, nerfing your progress heavily. I have no idea if this is intentional or not, but since it is the Tesla's ball lightning, I think it should count towards kill quests.

Steps To Reproduce

1: Find a level with a kill quest for Tesla
2: Place ONLY a Tesla and level it up to level 20
3: Select it's ultimate ability
4: Wait for it to spawn a ball lightning
5: Watch as enemies come out but the mission progress increases every 5-ish kills (depending on the number of ball lightnings)
6: Be sad :(

TagsBug, Tesla (Tower)

Relationships

duplicate of 0002049 feedbacktherainycat Problems with Tesla's Ultimate 

Activities

therainycat

therainycat

2023-05-09 20:42

administrator   ~0002121

Last edited: 2023-05-09 20:44

View 2 revisions

Technically it applies the "Ball lightning" ability, which counts as an ability kill and there's nothing wrong with it, but its connection to Tesla is misleading indeed. Keeping this issue for the future thinking - can't say for sure how it'll get fixed because this ability will be reworked in Season 3

therainycat

therainycat

2023-05-09 20:43

administrator   ~0002122

Quest can be completed by keeping your Tesla tower from reaching level 20 or by selecting the "Powerful" ability instead

Issue History

Date Modified Username Field Change
2023-04-26 00:46 IN_FIAR New Issue
2023-04-30 01:23 IN_FIAR Tag Attached: Bug
2023-04-30 01:23 IN_FIAR Tag Attached: Tesla (Tower)
2023-05-09 20:42 therainycat Note Added: 0002121
2023-05-09 20:42 therainycat Assigned To => therainycat
2023-05-09 20:42 therainycat Status new => acknowledged
2023-05-09 20:43 therainycat Priority high => normal
2023-05-09 20:43 therainycat Note Added: 0002122
2023-05-09 20:44 therainycat Note Edited: 0002121 View Revisions
2023-12-20 23:02 therainycat Status acknowledged => closed
2023-12-20 23:02 therainycat Resolution open => duplicate
2023-12-20 23:02 therainycat Relationship added duplicate of 0002049