View Issue Details

IDProjectCategoryView StatusLast Update
0000497Infinitode 2[All Projects] Infinitode 2public2021-05-28 12:54
ReporterAnonymousAssigned Toadministrator  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformMobileOSAndroidOS VersionAny
Product Version 
Target VersionFixed in Version1.8.0 
Summary0000497: Selling items with many items in inventory causes crash
Description

If you have too many individual items in your inventory, you cannot sell items, as it will cause the game to crash. The solution seems to be to open a custom map editor and sell the items in the individual tabs, however this can have some serious slowdown as well, especially in the portals/bases tab. This is still an issue in the main menu even when selecting a different quantity of items (for example if I have 20,000 road tiles, selling 1, 19,000, or all of them still causes the crash).

Steps To Reproduce

Get a large number of unique items in your inventory, and attempt to sell them.

TagsNo tags attached.
Attach Tags

Activities

Anonymous

Anonymous

2020-04-24 14:30

reporter   ~0000674

have the same problem. Game laggs when I open inventory

Issue History

Date Modified Username Field Change
2020-02-03 18:22 Anonymous New Issue
2020-04-24 14:30 Anonymous Note Added: 0000674
2020-06-04 23:49 administrator Assigned To => administrator
2020-06-04 23:49 administrator Status new => acknowledged
2020-12-04 18:02 therainycat Status acknowledged => resolved
2020-12-04 18:02 therainycat Resolution open => fixed
2020-12-04 18:02 therainycat Fixed in Version => 1.8.0
2021-05-28 12:54 administrator Status resolved => closed