View Issue Details

IDProjectCategoryView StatusLast Update
0000296Infinitode 2[All Projects] Infinitode 2public2019-12-05 11:53
ReporterDarth_Dan Assigned Totherainycat  
PriorityhighSeveritymajorReproducibilitysometimes
Status closedResolutionduplicate 
PlatformMobileOSAndroidOS VersionAny
Product Version 
Target VersionFixed in Version 
Summary0000296: Time-delayed research does not stay on completion
Description

After starting a research which has a time limit (for example the tower "generations") there is a chance to not acquire the result when the timer runs out if the game is closed at that moment.

Steps To Reproduce
  • Start a research that does not complete instantly (is delayed)
  • During the pause close the game (not through the dedicated close button, just switch apps via the "home" button
  • Use other apps that consume memory and therefore cause the game to actually close (as opposed to running in a suspended state)
  • After duration ends (should also test if opened before duration end, but without opening the research tree), open the game and check the research in question
  • If bug occurs, the research should be reset to "not started" state
Additional Information

Resources are gone despite the research being "cancelled".

TagsResearches
Attach Tags

Relationships

duplicate of 0000276 closedtherainycat Research disappeared 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2019-12-03 13:27 Darth_Dan New Issue
2019-12-03 13:27 Darth_Dan Tag Attached: Researches
2019-12-05 11:53 therainycat Assigned To => therainycat
2019-12-05 11:53 therainycat Status new => closed
2019-12-05 11:53 therainycat Resolution open => duplicate
2019-12-05 11:53 therainycat Relationship added duplicate of 0000276