View Issue Details

IDProjectCategoryView StatusLast Update
0000201Infinitode 2[All Projects] Infinitode 2public2019-12-12 15:04
ReporterSWOOSH Assigned Totherainycat  
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformMobileOSAndroidOS VersionAny
Product Version 
Target Version1.6.0Fixed in Version1.6.0 
Summary0000201: Tower Stat Equations Bug or Tooltip Error
Description

Cannon Damage is used for this calculation example.

Cannon Damage: 14.3 (no tiles no research just plain Tower)
Now all the research (max endless):
.002x10 pre level 10
.005x40 post level 10
(With research power is 101% at start)
.01(Power)
.05(Storyline)
.45(Global)
.45(Cannon)
.03(Star)
.03(Star)
.06(Star)
.02(Star)
.05(Generation)
Multipicative:
1-(1-.05)(1-.45)(1-.45)(1-.03)(1-.03)(1-.06)(1-.02)(1-.05)(1-.01)=0.76573
14.3*1.76573=25.249939 Damage
14.3-(1-.05)(1-.45)(1-.45)(1-.03)(1-.03)(1-.06)(1-.02)(1-.05)(1-.01)=14.061
14.3+14.061=28.361 Damage

Additive:
.01+.05+.45+.45.+.03+.03+.06+.02+.05=115%
14.3*215%=30.745

Displayed Cannon Damage: 27.3

Additional Information

Initially I did this with all stats, because I was never able to get an answer that matched with any of them I thought I was wrong. Until someone posted the stats a Base with Attack Speed Vs their Tower. So I tested that too but with damage versus Cannon again.

Cannon Damage: 14.3 (no tiles no research just plain Tower)
20% Damage Base with Research Disabled.
14.3*1.2=17.16
Displayed Cannon Damage: 16.8

TagsNo tags attached.
Attach Tags

Activities

therainycat

therainycat

2019-11-27 04:38

administrator   ~0000179

Thanks for the detailed report.
There's a visual bug of numbers formatting in 1.5.4, will need to check if the problem persists in 1.6.0

Issue History

Date Modified Username Field Change
2019-10-21 20:33 SWOOSH New Issue
2019-11-27 04:38 therainycat Note Added: 0000179
2019-11-27 04:38 therainycat Status new => acknowledged
2019-11-27 04:38 therainycat Target Version => 1.6.0
2019-12-12 15:04 therainycat Assigned To => therainycat
2019-12-12 15:04 therainycat Status acknowledged => closed
2019-12-12 15:04 therainycat Resolution open => fixed
2019-12-12 15:04 therainycat Fixed in Version => 1.6.0