View Issue Details

IDProjectCategoryView StatusLast Update
0000535Infinitode 2[All Projects] Infinitode 2public2021-05-28 12:55
Reporter53w4 Assigned Toadministrator  
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
PlatformMobileOSAndroidOS VersionAny
Product Version 
Target VersionFixed in Version1.8.0 
Summary0000535: Performance tanks on massive inventory
Description

If a player has an absurd of Bases and Portals, upon trying to open Inventory's 2nd tab the game will either be forced into a pseudo-permanent FPS drop until restart or become fully unresponsive for a prolonged period of time.

Steps To Reproduce

1) Obtain an absurd amount of Green Papers/Accelerator (how absurd is up to you) (via how is also up to you)
2) Use the Green Papers/Accelerator to open chests to increase the amount of tiles, bases and portals.
3) Open Inventory, navigate to Tiles/2nd tab and watch as FPS drops or the game become unresponsive.

Additional Information

Problem seems to worsen on v1.7.0 compared to v1.6.4 but unsure due to v1.7.0 was on a LG Stylus 3 and v1.6.4 was on Nox emulator with the following configuration: 2 Core CPU, 1024MB RAM, graphics rendering on OpenGL+, 1280x720.

Workaround found: Back up the save file using Helium, load onto computer and manually edit the "_prefV1.Progress.xml" file to wipe out the Inventory but also will reset Trophies and etc., thus forcing a reset of level progress to re-obtain the trophies.

Tags1.7.1
Attach Tags

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-02-22 12:37 53w4 New Issue
2020-02-22 12:37 53w4 Tag Attached: 1.7.1
2020-03-05 17:56 administrator Assigned To => administrator
2020-03-05 17:56 administrator Status new => acknowledged
2020-12-04 18:08 therainycat Status acknowledged => resolved
2020-12-04 18:08 therainycat Resolution open => fixed
2020-12-04 18:08 therainycat Fixed in Version => 1.8.0
2021-05-28 12:55 administrator Status resolved => closed