View Issue Details

IDProjectCategoryView StatusLast Update
0001758Infinitode 2[All Projects] Infinitode 2public2021-06-17 13:18
ReporterLdream Assigned Totherainycat  
PriorityhighSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformDesktopOSWindowsOS VersionAny
Product Version 
Target VersionFixed in Version1.8.3 
Summary0001758: SPLASH ultimate will crash the process of game.
Description

(only) the game crashes because of the SPLASH ultimate.
(more in step to reporduce and additional information)

Steps To Reproduce

the things i certain confirm:
1.appears in SPLASH ultimate.
2.appears at the time when BROOT and Constructor.
3.if a regular near the enemy, the game will lag and for seconds then restore to normal.
the things i can't certain confirm but it happened:
1.appears at the time after i PAUSE the game and use MAGNET and BLIZZARD ability.
2.I tested when to crash, and the result is if there is a BLAST, the possibility of crash will increase a lot.

Additional Information

when the crash happened a circle of spikes will come out from the invincible enemy and if you are in the endless mode, the level of splash will rocket to 100 level(if you have 100 upgrade)
my own guess:the error comes from the invincible mechanism.
the damage will 1.11.1*1.1...... (because it didn't show on the screen this calculate will be extremely fast)
then the damage out of range (maybe 1.7e308) game crashes.

TagsNo tags attached.
Attach Tags

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2021-06-15 16:56 Ldream New Issue
2021-06-17 13:18 therainycat Assigned To => therainycat
2021-06-17 13:18 therainycat Status new => resolved
2021-06-17 13:18 therainycat Resolution open => fixed
2021-06-17 13:18 therainycat Fixed in Version => 1.8.3